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Learning Objectives
After completing this chapter, you will be able to:
• Use the Mirror and Align tools
• Create AEC extended objects
• Create doors and windows
 



INTRODUCTION
In this chapter, you will learn to create the default objects and patch grids in 3ds Max. Also, you will
learn to use the Mirror and Align tools while modeling the objects with the help of various primitives
and default objects. In addition, you will learn to create doors and windows.
 
MIRROR TOOL
Menu bar: Tools > Mirror
Main Toolbar: Mirror

THE MIRROR TOOL IS USED TO MIRROR OR CLONE THE SELECTED

OBJECT ABOUT THE CENTER OF THE CURRENT COORDINATE SYSTEM.
YOU CAN ALSO MOVE THE OBJECT WHILE MIRRORING ITS
ORIENTATION. TO MIRROR AN OBJECT, SELECT IT IN A VIEWPORT AND

CHOOSE THE MIRROR TOOL FROM THE MAIN TOOLBAR; THE

MIRROR: SCREEN COORDINATES DIALOG BOX WILL BE DISPLAYED,

REFER TO FIGURE 4-1. SET THE PARAMETERS IN THIS DIALOG BOX AND

CHOOSE THE OK BUTTON TO MIRROR THE OBJECTS. THE TWO AREAS

IN THIS DIALOG BOX ARE DISCUSSED NEXT.
 
Mirror Axis Area
Select the X, Y, Z, XY, YZ, or ZX radio button in the Mirror Axis area to define the
direction of the object while mirroring. By default, the X radio button is selected.
The value in the Offset spinner defines the distance of the mirrored object from the
original one.
Figure 4-1 The Mirror: Screen Coordinates dialog box

 
Clone Selection Area
The Clone Selection area is used to define the type of clone created by the Mirror tool. By default,
the No Clone radio button is selected in this area. As a result, the selected object is mirrored but not
retained. Select the Copy radio button to retain the selected object after mirroring. You can also
change the position of the copied object by entering the required value in the Offset spinner in the



Mirror Axis area. Select the Instance radio button to mirror the selected object as an instance. Select
the Reference radio button to mirror a reference of the selected object to a specified position.
 
An instance is a type of clone in which the changes are reflected when they are made in the original
object. Also, if you make any change in the instanced object, then it will transfer to the original
object.
 
A reference object is similar to an instance object with the only difference that the changes made in
the reference object are not reflected in the original object.
ALIGN TOOL
Menu bar: Tools > Align > Align
Main Toolbar: Align
Keyboard: ALT+A

The Align tool enables you to align the current object with the target object. To align an object
using the Align tool, select the current object and then choose the Align tool from the Main Toolbar;
the shape of the cursor will be changed, as shown in Figure 4-2. Move the cursor over the target
object in the viewport and click on it; the Align Selection (X) dialog box will be displayed, refer to
Figure 4-3. Here, X refers to the name of the target object. You need to use the options in the Align
Selection (X) dialog box to align the objects. Various areas and options in this dialog box are
discussed next.
 
Figure 4-2 The align cursor in the Top viewport

Figure 4-3 The Align Selection (Sphere001) dialog box
 

Align Position Area
You can select the check box(es) in this area to specify the axis along which you want to align the
object.
 



Current Object/Target Object Group
The Minimum, Center, Pivot Point, or Maximum radio button in the Current Object and Target
Object groups can be selected to specify different points on the current and target objects to be used
for alignment.
 
Align Orientation Area
You can select the check box(es) in this area to specify the axis or axes about which you want to align
the orientation. By default, all check boxes are cleared.
Match Scale Area
You can select the check box(es) in this area to match the scale axes values between the current and
target object.
 

Note
1. You should try different combinations of axes in the Align Position area. Also, try using different
options in the Current Object and Target Object areas to notice the difference.
 
2. If the objects have been not scaled before, the Match Scale area will not change the size of the
objects.
 
AEC EXTENDED PRIMITIVES
In 3ds Max, there are some in-built objects such as trees, railings, walls, and so on, which are known
as AEC extended objects. The AEC extended objects are used in the architectural, engineering, and
construction fields. All AEC extended objects can be created dynamically using the mouse or by
entering the parameters in the Keyboard Entry rollout.
 
To create an AEC extended object, you need to choose Create >
Figure 4-4 Various rollouts to create a tree

Geometry in the Command Panel; the Standard Primitives option will be displayed by default in
the drop-down list. Select the AEC Extended option from the drop-down list and activate the
viewport in which you want to create the objects. Next, choose the corresponding tool from the
Object Type rollout. In this section, you will learn to create and modify the AEC extended objects



using various tools available in the Object Type rollout.
 
Creating a Foliage
Menu bar: Create > AEC Objects > Foliage
Command Panel: Create > Geometry > AEC Extended >
Object Type rollout > Foliage
To create a foliage or a tree, activate the viewport in which you want to create it. Next, choose the
Foliage tool from the Object Type rollout; the Name and Color, Keyboard Entry, Favorite Plants,
and Parameters rollouts will be displayed, as shown in Figure 4-4.
 
In the Favorite Plants rollout, double-click on a tree; the selected tree will be displayed in the
viewports. One of the sample trees is shown in Figure 4-5. Alternatively, you can create a tree by
dragging it from the Favorite Plants rollout to the desired location in the viewport. Also, you can
select one of the trees from the Favorite Plants rollout and then click in the viewport at the desired
location to place it. You need to choose the Zoom Extents All tool to view the entire tree in the
viewports.
 
Various rollouts used to create and modify the tree are discussed next.
 

Note
1. The options in the Name and Color rollout are the same for all AEC extended objects.
 
2. The Keyboard Entry rollout is used to create various objects by entering the parameters using
the keyboard. The method of creating these objects is the same as discussed earlier in Chapter 2.
However, the railing object cannot be created using the keyboard, therefore, it does not have the
Keyboard Entry rollout.
 
Favorite Plants Rollout
The Favorite Plants rollout has a palette consisting of a list of default
Figure 4-5 A tree created
using the Foliage tool

trees to create them in the viewport. By default, the Automatic Materials check box is selected. It is
used to assign the default material to the trees. If you clear this check box and create a tree, then the
tree created will not show any material. Also, the default color will be displayed in it. Choose the
Plant Library button below the Automatic Materials check box; the Configure Palette dialog box
will be displayed. This dialog box is used to provide information such as Name, Fav., Scientific
Name, Type, Description, and # Faces about all the default trees in the Favorite Plants rollout. You



can also use this dialog box to remove or add a particular plant from the palette in the Favorite
Plants rollout. To do so, select the name of a plant from the Configure Palette dialog box and
choose the Remove from Palette button; the status in the Fav. column will change to no. Now,
choose the OK button; the removed plant will not be displayed in the Favorite Plants rollout.
Similarly, to display a plant in the Favorite Plants rollout, select the name of the plant from the
Configure Palette dialog box, and then choose the Add to Palette button; no will switch to yes in
the Fav. column. Next, choose the OK button to save the changes.
 

Note
To modify the default material of the trees, you need to use the Material Editor
dialog box, which will be discussed in detail in the later chapters.
 
Parameters Rollout
The options in this rollout are used to modify the tree created using
Figure 4-6 The Parameters
rollout

the Foliage tool. To do so, select the tree and choose the Modify tab in the Command Panel; the
Parameters rollout will be displayed, as shown in Figure 4-6. Enter a new value in the Height
spinner to modify the height of the tree. The value in the Density spinner varies from 0.0 to 1.0 and is
used to specify the amount of leaves and flowers in the tree. The value in the Pruning spinner varies
from -0.1 to 1.0 and is used to reduce the branches of the tree, refer to Figures 4-7 and 4-8.
 
Choose the New button to view the variation in the placement of leaves, branches, and the angle of
trunk of the selected plant. When you choose the New button, the value in the Seed spinner changes
accordingly, showing the possible variation in the selected tree. By default, the Generate Mapping
Coords check box is selected. It is used to apply default mapping coordinates to the plant. The other
areas in the Parameters rollout are discussed next.

Figure 4-7 A tree with the 0 value in the Pruning spinner



Figure 4-8 A tree with the 0.5 value in the Pruning spinner
Show Area

The options in this area are used to display leaves, trunk, fruits, branches, flowers, and roots.
Select the check boxes to display the corresponding parts of a tree.

 

Note
The Show area will display only those options which are relevant to the selected tree. For
example, if you select a tree that does not have flowers, the Flowers check box will not be
available.
 

Viewport Canopy Mode Area
The options in this area are used to display the plant in the canopy mode in the viewports. The
canopy of a plant is a type of covering area which covers the outermost parts of the tree such as
leaves, branches, and trunk. By default, the When Not Selected radio button is selected. This
button is used to display the tree in canopy mode in the viewport, when the tree is not selected.
Select the Always radio button to display the tree always in the canopy mode, whether it is selected
or not. Select the Never radio button to display the tree without canopy mode.

 
Level-of-Detail Area
This area is used to define how a tree will be displayed at the time of rendering. Select the Low
radio button to display the lowest detail of a tree. It renders the tree in the canopy mode, as shown
in Figure 4-9. Select the Medium radio button to render the tree with less number of faces in the
branches and trunk, as shown in Figure 4-10. By default, the High radio button is selected. It is
used to render the tree with all its faces in the branches and trunk. It will provide the highest detail
of a tree, as shown in Figure 4-11.

Figure 4-9 The tree with low level of detail at rendering
Figure 4-10 The tree with medium level of detail at rendering



Figure 4-11 The tree with high level of detail at rendering
 

Creating a Railing
Menu bar: Create > AEC Objects > Railing
Command Panel: Create > Geometry > AEC Extended >
Object Type rollout > Railing
To create a railing, activate the viewport in which you want to create it and then choose the Railing
tool from the Object Type rollout; the Name and Color, Railing, Posts, and Fencing rollouts will be
displayed, as shown in Figure 4-12. Now, press and hold the left mouse button on the left side of a
viewport and then drag the cursor to the right side to specify the length of the railing. Release the left
mouse button to set the length. Now, move the cursor up to specify the height of the railing and click
on the screen; the railing will be created in the viewports, refer to Figure 4-13. You may need to use
the Zoom Extents All tool to view the entire railing.
 
Various rollouts used to modify the railing are discussed next.
 
Railing Rollout
The Pick Railing Path button is used to create railing paths using the splines. To create a railing
according to the railing path or the spline, first create a spline and a railing in the viewport. Next,
select the railing and choose the Modify tab in the Command Panel and then choose the Pick Railing
Path button in the Railing rollout and move the cursor over the spline in the viewport; the pick cursor
will be displayed. Next, click on the spline; the railing will be aligned to the spline. Now, set a value
in the Segments spinner to specify the number of segments in the railing. Select the Respect Corners
check box to put the corners in the railing to match the corners of the railing path. The Segments
spinner and the Respect Corners check box will be activated only if you create a railing using the
railing path. The value in the Length spinner specifies the length of the railing. The areas in the
Railing rollout are discussed next.
 

Top Rail Area
The top rail is the topmost part of the railing, refer to Figure 4-13. The options in the Top Rail area
are used to modify the top rail. The Profile drop-down list is used to define the cross-section shape
of the top rail. Select the Round or the Square option from the drop-down list to make the top rail
round or square, respectively. Select the none option to remove the top rail from the railing. The
values entered in the Depth, Width, and Height spinners specify the depth, width, and height of the
top rail, respectively, refer to Figure 4-14.

Figure 4-12 Partial view of various rollouts to create a railing



Figure 4-13 The railing with different parts labeled

Figure 4-14 The railing with different dimensions
 

Lower Rail(s) Area
The lower rail is placed below the top railing, refer to Figure 4-13. The options  in the Lower Rail
area are used to modify the lower rail of the railing. The options in the Profile drop-down list are
used to define the shape of the cross-section of the lower rail. Select the Round or Square option
from the drop-down list to make the lower rail round or square, respectively. Select the none
option to remove the lower rail from the railing. The value in the Depth spinner specifies the depth
of the rail, whereas the value in the Width spinner specifies the width of the lower rail. Choose the
Lower Rail Spacing button on the left side of the Lower Rail(s) area; the Lower Rail Spacing
dialog box will be displayed, as shown in Figure 4-15. In this dialog box, select the Count check
box, if it is not already selected. The value in the spinner on the right of this check box specifies the
number of lower rails in the railing. Choose the Close button to close the dialog box.



Posts Rollout
The posts are the left and right supports of the railing, refer

Figure 4-15 The Lower Rail Spacing dialog box
to Figure 4-13. The options in the Posts rollout are used to modify them. Most of the options in this
rollout are the same as those discussed in the Lower Rail(s) area of the Railing rollout, except the
Extension spinner. The value in the Extension spinner is used to extend the posts of the railing from
the bottom of the top rail, as shown in Figure 4-16.

 
Fencing Rollout
The fencing is placed in between the posts of the railing, refer to Figure 4-13. The options in the
Fencing rollout are used to modify it. The options in the Type drop-down list define the type of
fencing in the railing. If you select the (none) option in the Type drop-down list, the fence will not be
displayed and the options in the Picket and Solid Fill areas will become inactive. If you select the
Pickets option in the Type drop-down list, then the pickets will be displayed in between the posts, as
shown in Figure 4-17. Also, the Picket area will be activated in this rollout. If you select the Solid
Fill option in the Type drop-down list, then the solid box type shape will be displayed in between the
posts, as shown in Figure 4-18. Also, the Solid Fill area will be activated. The areas in the Fencing
rollout are discussed next.

 

Figure 4-16 The railing with the extension in the posts

Figure 4-17 The railing with the picket type of fencing
 

Picket Area
You need to select the Pickets option from the Type drop-down list to activate this area. The



Profile, Depth, Width, and Extension options in this area are the same as those discussed in the
Posts rollout. The value in the Bottom Offset spinner is used to set the height of the picket from
the bottom of the railing, refer to Figure 4-19.
Solid Fill Area
Select the Solid Fill option from the Type drop-down list to activate this area. The value in the
Thickness spinner is used to set the thickness of the solid fill. The value in the Top Offset spinner
is used to set the distance of the solid fill from the bottom of the top railing. The value in the
Bottom Offset spinner is used to set the distance of the solid fill from the bottom of the railing.
The value in the Left Offset spinner is used to set the distance of the solid fill from the left post.
The value in the Right Offset spinner is used to set the distance of the solid fill from the right post,
refer to Figure 4-20.

Figure 4-18 The railing with the solid fill type of fencing

 

Figure 4-19 The bottom offset in the picket fencing

Figure 4-20 Various offsets in the solid fill fencing
 

Creating a Wall
Menu bar: Create > AEC Objects > Wall
Command Panel: Create > Geometry > AEC Extended >
Object Type rollout > Wall
To create a wall, activate the Top viewport and then choose the Wall tool from the Object Type
rollout; the Name and Color, Keyboard Entry, and Parameters rollouts will be displayed, as
shown in Figure 4-21. Now, in the Parameters rollout, set the width and height by entering values in
the Width and Height spinners, respectively. Next, click on the left of the Top viewport to create the
starting point of the wall. Drag the cursor to the right to define the length of the wall and then click on
the screen. Now, right-click to exit the command; a wall segment will be created, as shown in Figure



4-22. If you want to create another segment of the wall in continuation, then you need to repeat the
same procedure as followed for the first segment without right-clicking. Next, to create a closed wall,
click on the starting point of the first wall segment; the Weld Point? message box will be displayed,
as shown in Figure 4-23. Choose the Yes button in this dialog box; a closed wall will be displayed,
as shown in Figure 4-24. Next, right-click to exit the command.
Figure 4-21 Various rollouts to create a wall

Figure 4-23 The Weld Point? message box

Figure 4-24 A closed wall displayed

Figure 4-22 The wall
segment displayed

 
Various rollouts used to modify the wall are discussed next.
 
Keyboard Entry Rollout
This rollout is used to create a wall by entering the parameters in the Keyboard Entry rollout. To do
so, expand the Keyboard Entry rollout. Enter the values in the X, Y, and Z spinners to specify the
position of the starting point of the wall segment in the viewport along the axes of the home grid or a
grid object. Now, choose the Add Point button to add a point. Repeat the same procedure to create
another segment. Next, choose the Close button to create a closed wall. Choose the Finish button to
end the creation of the wall.



 
The Pick Spline button is used to create wall using the splines. To create a wall according to the wall
path or the spline, first create a spline in the viewport. Next, choose the Wall tool from the Object
Type rollout, and then choose the Pick Spline button in the Keyboard Entry rollout. Next, move the
cursor over the spline in the viewport; the pick cursor will be displayed. Next, click on the spline; the
wall will be created and aligned to the spline.
 

Note
The procedure of creating a spline is discussed in detail in Chapter 5.
 
Parameters Rollout
In this rollout, enter the values in the Width and Height spinners to define the width and height of the
wall, respectively. The Justification area in the Parameters rollout is discussed next.
 

Justification Area
The options in this area are used to align the wall to its baseline. The baseline is the line between
the front and back sides of a wall and it is equal to the thickness of the wall. By default, the Center
radio button is selected in this area and is used to align the wall at the center of its baseline. Select
the Left radio button to align the wall at the left edge of its baseline. Select the Right radio button
to align the wall at the right edge of its baseline.

 
Edit Object Rollout
Select one of the walls in the viewport and choose the Modify tab in the

Figure 4-25 The Edit Object rollout
Command Panel; the Edit Object rollout will be displayed, as shown in Figure 4-25. In this rollout,
the Attach button is used to attach multiple walls to each other in the scene. To do so, choose the
Attach button; the button will be highlighted. Now, move the cursor over the wall in the viewport; the
pick cursor will be displayed. Next, click on the wall to be attached with the selected wall; the walls
will get attached to each other. When you select another wall, it will automatically take the same
material as that of the selected wall. Choose the Attach Multiple button; the Attach Multiple dialog
box will be displayed, with a list of all the walls in the viewport. From the list, select the multiple
walls that you want to get attached by pressing and holding the CTRL key. Next, choose the Attach
button; multiple walls will be attached to the selected wall.
 
CREATING DOORS
In 3ds Max, there are three tools to create the in-built doors. These tools are Pivot, Sliding, and
BiFold. You can use these doors while creating houses, offices, rooms, and so on. To create doors,



you need to choose Create > Geometry from the Command Panel; the Standard Primitives option
will be displayed in the drop-down list. Select the Doors option from the drop-down list and activate
the viewport in which you want to create the doors. Next, choose the corresponding tool from the
Object Type rollout. In this section, you will learn to create and modify different types of doors
using various tools available in the Object Type rollout.
 
Creating a Pivot Door
Menu bar: Create > AEC Objects > Pivot Door
Command Panel: Create > Geometry > Doors > Object Type rollout > Pivot
The pivot door is joined or hinged only on one side. To create a pivot door, choose the Pivot tool
from the Object Type rollout; the Name and Color, Creation Method, Parameters, and Leaf
Parameters rollouts will be displayed, as shown in Figure 4-26.
Activate the Top viewport and press and hold the left mouse button on the left of the viewport. Now,
drag the cursor to the right of the viewport and release the left mouse button to define the width. Next,
move the cursor up or down to define the depth of the door and click on the screen to set the depth.
Now, again move the cursor up or down to define the height of the door. Click on the screen; the pivot
door will be created in all viewports, refer to Figure 4-27.
Figure 4-26 Partial view of various rollouts to create a pivot door

Figure 4-27 The pivot door created in the viewport

 
Various rollouts used to create and modify the pivot door are discussed next.
 
Creation Method Rollout



The options in this rollout are used to create the pivot door dynamically. You can create the pivot
door using any of the two methods that are discussed next.
 

Width/Depth/Height
To create the door using this method, make sure the Width/Depth/Height radio button is selected.
Now, first you need to define the width and depth of the door, and then you need to move the cursor
to define the height, as discussed earlier while creating the pivot door dynamically.
Width/Height/Depth
To create the door using this method, you need to select the Width/Height/Depth radio button.
Now, first you need to specify the width and height of the door, and move the cursor to specify the
depth. To do so, press and hold the left mouse button on the left side of the viewport, drag the
cursor to the right of the viewport to specify the width of the pivot door, and release the left mouse
button. Next, move the cursor up to define the height of the door and click on the screen to set the
height. Next, move the cursor up or down to specify the depth of the door. Click in the viewport; the
pivot door will be created in all viewports.

 
Parameters Rollout
The options in this rollout are used to modify the pivot door. Select the pivot door and choose the
Modify tab in the Command Panel; the Parameters and Leaf Parameters rollouts will be
displayed. Enter the new values in the Height, Width, and Depth spinners to modify the height,
width, and depth of the pivot door, respectively. Select the Double Doors check box to create two
pivot doors, one on the left and other on the right, as shown in Figure 4-28. Select the Flip Swing
check box to change the direction of swing of the door. Select the Flip Hinge check box to change the
placement of the joint or the hinge of the pivot door on the opposite side. When you select the Double
Doors check box, the Flip Hinge check box becomes inactive. The value in the Open spinner is used
to specify the amount in degree to which the door will open, refer to Figure 4-29. The Frame area in
the Parameters rollout is discussed next.

Figure 4-28 A double pivot door

Figure 4-29 An opened double door



 
Frame Area
The options in this area are used to modify the frame of the pivot door. By default, the Create
Frame check box is selected. If you clear the Create Frame check box, then the other options in
this area will become inactive. Also, the frame will not be displayed in the door. Enter the values
in the Width and Depth spinners to specify the width and depth of the frame of the pivot door. The
value in the Door Offset spinner specifies the location of the door in reference to the frame.

Leaf Parameters Rollout
This rollout is used to modify the leaf of a door. Set a new value in

Figure 4-30 The modified door leaf
the Thickness spinner to modify the thickness of the leaf of the door. Enter a new value in the
Stiles/Top Rail spinner to modify the frame of the door leaf on the top, left, and right side, as shown
in Figure 4-30. Set a value in the Bottom Rail spinner to modify the frame at the bottom of the door
leaf. The value in the # Panels Horiz spinner specifies the horizontal panels on the leaf of the door.
The value in the # Panels Vert spinner specifies the vertical panels on the leaf of the door, refer to
Figure 4-30. The value in the Muntin spinner is used to specify the width of the gap between the
panels of the door leaf. The Panels area in the Leaf Parameters rollout is discussed next.
 

Panels Area
The options in this area are used to modify the panels on the door leaf. The three radio buttons in
this area are discussed next.

 
None
Select the None radio button; the panels will not be displayed in the door leaf.
 
Glass
Select the Glass radio button to create the glass panels, refer to Figure 4-30. Also, the Thickness
spinner will be activated. It is used to set the thickness of the glass panel.
 
Beveled
Select the Beveled radio button to create the beveled panels, as shown in Figure 4-
31. When you select the Beveled radio button, the options under this radio button
will be activated. The Bevel Angle spinner is used to define the angle between the
outer surface of the door and the panel surface. The Thickness 1 spinner is used to
define the outer thickness of the panel. The Thickness 2 spinner is used to define the
thickness of the starting point of the bevel. The Middle Thick spinner is used to
define the inner thickness of the panel. The Width 1 spinner is used to define the



width of the starting point of the bevel and the Width 2 spinner is used to define the
inner width of the panel.

Figure 4-31 A door with the beveled panels

 
Creating a Sliding Door
Menu bar: Create > AEC Objects > Sliding Door
Command Panel: Create > Geometry > Doors > Object Type rollout > Sliding
A sliding door has two door components, one is fixed, whereas the other slides or moves over the
fixed component to open. To create a sliding door, choose the Sliding tool from the Object Type
rollout; the Name and Color, Creation Method, Parameters, and Leaf Parameters rollouts will be
displayed.
 
To create the sliding door, follow the same procedure as you did for the pivot door; a
sliding door will be created, as shown in Figure 4-32.
 
The options in the Name and Color, Creation Method, Parameters, and Leaf
Parameters rollouts are the same as discussed in the pivot door. However, some
options in the Parameters rollout are different and these are discussed next.

Figure 4-32 A sliding door

 
Select the Flip Front Back check box to choose the component that you want to place in the front.
Select the Flip Side check box to change the fixed component to the sliding component.
Creating a BiFold Door
Menu bar: Create > AEC Objects > BiFold Door
Command Panel: Create > Geometry > Doors > Object Type rollout > BiFold
The bifold door has two door components and two joints in it. To

Figure 4-33 A bifold door



create the bifold door, choose the BiFold tool from the Object Type rollout; the Name and Color,
Creation Method, Parameters, and Leaf Parameters rollouts will be displayed in the Command
Panel. Now, create a bifold door dynamically using the same method as discussed for creating the
pivot door; a bifold door will be created, as shown in Figure 4-33.
 
The options in the Name and Color, Creation Method, Parameters, and Leaf Parameters rollouts
are the same as those discussed for the pivot door.
 
CREATING WINDOWS
In 3ds Max, there are six tools to create different types of default windows such as Awning,
Casement, and so on. You can use these windows at various places for architectural designs.
 
To use these tools for creating the windows, choose Create > Geometry in the Command Panel; the
Standard Primitives option will be displayed in the drop-down list. Now, select the Windows
option from this drop-down list; various tools will be displayed in the Object Type rollout. In this
section, you will learn to create various types of windows using these tools.
 
Creating an Awning Window
Menu: Create > AEC Objects > Awning Window
Command Panel: Create > Geometry > Windows > Object Type rollout > Awning
An awning window has one or more cases that are joined at its top. To create an awning window,
choose the Awning tool from the Object Type rollout; the Name and Color, Creation Method, and
Parameters rollouts will be displayed, as shown in Figure 4-34.
Activate the Top viewport and press and hold the left mouse button on the left side of the viewport,
drag the cursor to the right side to specify the width of the window, and release the left mouse button.
Next, move the cursor up or down to define the depth of the window and click on the screen. Now,
move the cursor up or down to specify the height of the window. Click on the screen; the awning
window will be created in all viewports, refer to Figure 4-35.
The options in the Name and Color and Creation Method rollouts are the same for all windows as
those discussed in the pivot door.
 
Parameters Rollout
The options in this rollout are used to modify the awning window. Select the awning window and
choose the Modify tab in the Command Panel; the Parameters rollout will be displayed. Enter new
values in the Height, Width, and Depth spinners to modify the height, width, and depth, respectively
of the awning window. The areas in the Parameters rollout are used to modify the window. These
areas are discussed next.



 
Frame
The options in this area are used to modify the frame of the window, refer to Figure 4-35. Enter a
value in the Horiz. Width spinner to set the width of the horizontal (top and bottom) frames of the
window. Enter a value in the Vert. Width spinner to set the width of the vertical (left and right)
frames of the window. Similarly, enter a value in the Thickness spinner to set the overall thickness
of the frame of the window.

Figure 4-34 Partial view of various rollouts to create an awning window

Figure 4-35 An awning window
 

Glazing
The Thickness spinner in this area is used to set the thickness of the glaze or the glass of the
window, refer to Figure 4-35.
 
Rails and Panels
This area is used to modify the panel of the window. Enter a value

Figure 4-36 An awning window with two panels

in the Width spinner to set the width of the fence in the panel. Enter a value in the Panel Count
spinner to set the number of panels in the window, as shown in Figure 4-36.
 
Open Window
The Open spinner in this area is used to open the window. Its value will be in
percentage.
 



Creating a Casement Window
Menu bar: Create > AEC Objects > Casement Window
Command Panel: Create > Geometry > Windows > Object Type rollout > Casement
A casement window has one or more cases that are joined on the sides. To create the casement
window, choose the Casement tool from the Object Type rollout; the Name and Color, Creation
Method, and Parameters rollouts will be displayed. Create a casement window dynamically using
the same method as discussed for creating the awning window. A casement window is shown in
Figure 4-37.
 
Parameters Rollout
The options in this rollout are the same as those discussed for the Awning tool, except the Casement
and Open Window areas. These areas are discussed next.
 

Casements Area
The options in this area are used to modify the panel of the window. Enter a value in the Panel
Width spinner to set the width of the fence in the panel. By default, the One radio button is selected
to create one panel in the window. If you want to create two panels in the window, as shown in
Figure 4-38, you need to select the Two radio button.

 
Figure 4-37 A casement window

Figure 4-38 A casement window with two panels

 
Open Window Area
The Open spinner in this area is used to open the window. Its value will be in percentage. Select
the Flip Swing check box to swap the swinging of the panel of the window.

 
Creating a Fixed Window
Menu bar: Create > AEC Objects > Fixed Window
Command Panel: Create > Geometry > Windows > Object Type rollout > Fixed
A fixed window cannot be opened. To create a fixed window, choose the Fixed tool from the Object
Type rollout; the Name and Color, Creation Method, and Parameters rollouts will be displayed.



Next, activate the Top viewport and follow the same method as discussed for creating the awning
window; a fixed window will be created, as shown in Figure 4-39.
 
Parameters Rollout
The options in this rollout are the same as those discussed in the Awning tool, except the Rails and
Panels area. This area is discussed next.
 

Rails and Panels Area
This area is used to modify the panel of the window. Enter a value in the Width spinner to set the
width of the fence in the panel. Set a value in the #Panels Horiz spinner to define the number of
horizontal divisions in the panel. Similarly, set a value in the #Panels Vert spinner to define the
number of vertical divisions in the panel. On selecting the Chamfered Profile check box, the rails
are chamfered between the glazed panels, refer to Figure 4-40.
 

Figure 4-39 A fixed window

Figure 4-40 A fixed window with horizontal and vertical divisions

Creating a Pivoted Window
Menu bar: Create > AEC Objects > Pivoted Window
Command Panel: Create > Geometry > Windows > Object Type rollout > Pivoted
A pivoted window has only one panel that is joined at the middle of the frame. When you open this
window, it will swing around the horizontal axis. To create a pivoted window, activate the viewport
and choose the Pivoted tool from the Object Type rollout; the Name and Color, Creation Method,
and Parameters rollouts will be displayed. Now, follow the same method as discussed while
creating the awning window; a pivoted window will be created, as shown in Figure 4-41.
Parameters Rollout
Most of the options in this rollout are the same as discussed for the Awning tool, except the Rails and
Pivots areas. These areas are discussed next.
 

Rails Area
This area is used to modify the panel of the window. Enter a value in the Width spinner to set the
width of the fence in the panel.



 
Pivots Area
When you open the window, by default it rotates about the horizontal axis. To rotate the window
about the vertical axis, select the Vertical Rotation check box; the window will be vertically
rotated, as shown in Figure 4-42.

Figure 4-41 A pivoted window rotated around the horizontal axis

Figure 4-42 A pivoted window rotated around the vertical axis

 
Creating a Projected Window
Menu bar: Create > AEC Objects > Projected Window
Command Panel: Create > Geometry > Windows > Object Type rollout > Projected
A projected window has three panels in which the top one remains

Figure 4-43 A projected window
still, and the other two swing in the directions opposite to each other. To create a projected window,
activate the viewport and choose the Projected tool from the Object Type rollout; the Name and
Color, Creation Method, and Parameters rollouts will be displayed. Now, follow the same method
as discussed while creating the awning window; a projected window will be created, as shown in
Figure 4-43.
 
Parameters Rollout
Most of the options in this rollout are the same as discussed for the Awning tool, except the Rails and
Panels area. This area is discussed next.
 

Rails and Panels Area
This area is used to modify the panel of the window. Set the value in the Width spinner to specify
the width of the fence in the panel. Set the value in the Middle Height spinner to define the height
of the middle panel relative to the frame of the window. Similarly, set the value in the Bottom



Height spinner to define the height of the bottom panel relative to the frame of the window.
 
Creating a Sliding Window
Menu bar: Create > AEC Objects > Sliding Window
Command Panel: Create > Geometry > Windows > Object Type rollout > Sliding
A sliding window has two panels in which one remains still and the other one slides to open. To
create a sliding window, activate the viewport and choose the Sliding tool from the Object Type
rollout; the Name and Color, Creation Method, and Parameters rollouts will be displayed.
 
Now, create a sliding window dynamically using the same method as discussed while creating the
awning window; a sliding window will be created, as shown in Figure 4-44.
Parameters Rollout
Most of the options in this rollout are the same as those discussed for the Awning tool, except the
Rails and Panels and Open Window areas. These areas are discussed next.
 

Rails and Panels Area
This area is used to modify the panel of the window. Set the value in the Rail Width spinner to set
the width of the fence in the panel. Set the value in the #Panels Horiz spinner to define the number
of horizontal divisions in the panel. Set the value in the #Panels Vert spinner to define the number
of vertical divisions in the panel. On selecting, the Chamfered Profile check box, the rails
between the glazed panels will be chamfered, as shown in Figure 4-45.
 
Open Window
The Open spinner in this area is used to open the window and its value will be in percentage. By
default, the Hung check box is selected. As a result, the panel slides in the vertical direction. Clear
the Hung check box to slide the panel in the horizontal direction, refer to Figure 4-46.

Figure 4-44 The sliding window

Figure 4-45 The sliding window with two horizontal and vertical chamfered divisions

Figure 4-46 The sliding window with the horizontal sliding

 



CREATING STAIRS
In 3ds Max, there are four tools that are used to create different types of default stairs such as LType
Stair, Spiral Stair, and so on. To invoke these tools, choose Create > Geometry in the Command
Panel; the Standard Primitives option will be displayed in the drop-down list. Now, select the
Stairs options from the drop-down list; various tools will be displayed in the Object Type rollout. In
this section, you will learn to create various types of stairs using these tools.
 
Creating L-Type Stairs
Menu bar: Create > AEC Objects > L-Type Stair
Command Panel: Create > Geometry > Stairs > Object Type rollout > L-TypeStair
The L-type stairs have two stairways that are jointed at right angles
Figure 4-47 Partial view of various rollouts to create L-type stairs

to each other. To create the L-type stairs, choose the L-Type Stair tool from the Object Type rollout;
the Name and Color, Parameters, Carriage, Railings, and Stringers rollouts will be displayed, as
shown in Figure 4-47.
 
Now, activate the Top viewport. Press and hold the left mouse button on the left side of the viewport,
drag the cursor to the right side of the viewport to specify the length of the first stairway of the stairs,
and then release the left mouse button. Next, move the cursor up or down to define the length of the
second stairway of the stairs and then click on the screen. Now, move the cursor up to specify the
overall height of the stair and then click on the screen; the L-type stairs will be created in the
viewport, as shown in Figure 4-48.

Figure 4-48 The L-type open stairs created
 



Various rollouts used to create and modify the L-type stairs are discussed next.
 
Parameters Rollout
The options in this rollout are used to modify the L-type stairs. To do so, select the L-type stairs and
choose the Modify tab in the Command Panel; the Parameters, Carriage, Railings, and Stringers
rollouts will be displayed. The Parameters rollout has a number of options which can be used to
modify the stairs. These options are discussed next.
 

Type Area
The options in this area are used to define the type of stairs. By default, the Open radio button is
selected, and therefore the stairs with open steps are created, refer to Figure 4-48. Select the
Closed radio button to create the stairs with closed steps, as shown in Figure 4-49. Select the Box
radio button to create a support for the steps of the stairs, as shown in Figure 4-50.

Figure 4-49 The L-type closed stairs

Figure 4-50 The L-type box stairs

Generate Geometry Area
The options in this area are used to modify the stairs by incorporating the geometry shapes. Select
the Stringers check box to create the left and right support for the steps of the stairs, refer to Figure
4-51. Select the Carriage check box to create support for the steps of the stairs. Select the Left and
Right check boxes in the Handrail group to create the left and right handrails, as shown in Figure
4-51.

 
Layout Area
The options in this area are used to modify the dimensions of the stairs. Enter a value in the Length
1 spinner to set the length of the first stairway. Similarly, enter a value in the Length 2 spinner to
set the length of the second stairway. The value in the Width spinner is used to set the width of the
overall steps in the stairs. Enter a value in the Angle spinner to set the angle between the second
stairway and the landing of the stairs. Figure 4-52 shows an L-Type stair with its Angle value set to
zero.
 
Rise Area
There are three spinners in this area. These spinners are controlled by choosing the buttons
available on their left side. When you choose one of the buttons, the spinner on the right side of that



button becomes inactive. You can modify only two spinners at a time. Enter a value in the Overall
spinner to define the height of stairways. The Riser Ht spinner is used to set the height of the risers
in the stairs. The Riser Ct spinner is used to set the number of risers in the stairs. The riser is the
gap between the steps in a stairway.

Figure 4-51 The L-Type stairs with handrails, carriage, and stringers

Figure 4-52 The L-Type stairs with Angle value set to zero
 

Steps Area
Enter a value in the Thickness spinner to modify the thickness of the steps of the stairs. This
spinner is activated only if the Open radio button is selected in the Type area. Select the check box
on the left side of the Depth spinner; the Depth spinner will become active. Set a value in the
Depth spinner to modify the depth of the steps of the stairs.
 

Carriage Rollout
To activate the options in this rollout, make sure the Carriage check box in the Generate Geometry
area of the Parameters rollout is selected. In the Parameters area of the Carriage rollout, enter a
value in the Depth spinner to set the depth of the carriage. Enter a value in the Width spinner to set
the width of the carriage. Choose the Carriage Spacing button just below the Width spinner; the
Carriage Spacing dialog box will be displayed. Select the Count check box, if it is not already
selected. The value in the spinner on the right side of the Count check box specifies the number of
carriages in the stairs. Set the required value and then choose the Close button to close the dialog
box. The Spring from Floor check box in this rollout is used to control the starting point of the
carriage from the floor.
 
Railings Rollout
To activate the options in this rollout, you need to select one of the Handrail check boxes in the
Generate Geometry area of the Parameters rollout. Enter a value in the Height spinner to set the
height of the railing from the steps of the stairs. The Offset spinner is used to set the offset of the
railing from the ends of the steps. The value in the Segments spinner is used to set the number of
segments in the railing. The more the number of segments, smoother will be the railing. The value in



the Radius spinner is used to set the radius of the railing.
 
Stringers Rollout
To activate the options in this rollout, you need to select the Stringers check box in the Generate
Geometry area of the Parameters rollout. Enter a value in the Depth spinner to set the distance of
the stringers from the floor. The value in the Width spinner is used to set the width of the stringers.
The Offset spinner is used to set the distance of the stringers from the steps. The Spring from Floor
check box is used to control the starting point of the stringers from the floor.
 
Creating Spiral Stairs
Menu bar: Create > AEC Objects > Spiral Stair
Command Panel: Create > Geometry > Stairs > Object Type rollout > Spiral Stair
The spiral stairs have a spiral shaped staircase. To create the spiral stairs, choose the Spiral Stair
tool from the Object Type rollout; the Name and Color, Parameters, Carriage, Railings,
Stringers, and Center Pole rollouts will be displayed. To create the spiral stairs dynamically,
activate the Top viewport. Next, click on a point in the viewport to specify the center of the spiral
stair, hold the left mouse button, and drag it downward to specify the radius and width. Release the
left mouse button and move the cursor up or down to specify the overall rise in the height. Then, click
on the screen; the spiral stairs will be created in the viewport. Different types of spiral stairs are
shown in Figures 4-53, 4-54, and 4-55.

Figure 4-53 The spiral stairs
Figure 4-54 The closed spiral stairs

Figure 4-55 The spiral box stairs
 

Note
The options in the Carriage, Railings, and Stringers rollouts for the Spiral Stair, Straight Stair,



and U-Type Stair tools will be same as discussed for the L-Type Stair tool.
 
Parameters Rollout
In this rollout, the Type, Rise, and Steps areas are the same as discussed for the L-Type Stair tool.
However, the Generate Geometry and Layout areas are different and these areas are discussed
next.
 

Generate Geometry
The options in this area are used to modify the stairs by incorporating the geometry shapes. Select
the Stringers check box to create the left and right supports for the steps of the stairs. Select the
Carriage check box, if it is not already selected to create support for the steps of the stairs. Select
the Center Pole check box to create a pole at the center of the stairs, refer to Figure 4-53. Select
the Inside and Outside check boxes in the Handrail area to create the handrails on both sides.
Layout
The options in this area are used to modify the dimensions of the stairs. Select the CCW radio
button, if not already selected, to rotate the stairs in the counterclockwise direction. Select the CW
radio button to rotate the stairs in the clockwise direction. Enter a value in the Radius spinner to set
the radius of the spiral stairs. Enter a value in the Revs spinner to set the number of revolutions of
the stairs. The value in the Width spinner is used to set the width of the spiral stairs.
 

Center Pole Rollout
To activate the options in this rollout, you need to select the Center Pole check box in the Generate
Geometry area of the Parameters rollout. In the Parameters area of the Center Pole rollout, set a
value in the Radius spinner to set the radius of the center pole. Set the value in the Segments spinner
to set the number of segments of the center pole. Select the check box on the left side of the Height
spinner to activate it and set the value in this spinner to define the height of the pole.
 
Creating Straight Stairs
Menu bar: Create > AEC Objects > Straight Stair
Command Panel: Create > Geometry > Stairs > Object Type rollout > Straight Stair
The straight stairs have only one stairway. To create the straight stairs, activate the Top viewport and
choose the Straight Stair tool from the Object Type rollout; the Name and Color, Parameters,
Carriage, Railings, and Stringers rollouts will be displayed.
 
Press and hold the left mouse button on the left side of the viewport and drag the cursor to the right
side of the viewport to specify the length of the stairs. Release the left mouse button and then move
the cursor up or down to define the width of the stairs and click on the screen to set the width. Next,
move the cursor up or down to specify the height of the stairs. Click in the viewport; the straight stairs
will be created in all viewports, as shown in Figure 4-56. You can also create the closed and box
straight stairs in the same way as described in the L-type stairs, refer to Figures 4-57 and 4-58.



Figure 4-56 The straight stairs

Figure 4-57 The straight closed stairs

Figure 4-58 The straight box stairs
 
Parameters Rollout
In this rollout, all areas are same as discussed in the L-Type Stair tool, except the Layout area and
this area is discussed next.
 

Layout Area
The options in this area are used to modify the dimensions of the stairs. The value in the Length
spinner is used to set the length and the value in the Width spinner is used to set the width of the
stairs.

 
Creating U-Type Stairs
Menu bar: Create > AEC Objects > U-Type Stair
Command Panel: Create > Geometry > Stairs > Object Type rollout > U-TypeStair
The U-type stairs have two stairways parallel to each other in U shape. To create the U-type stairs,
activate the Top viewport and choose the U-Type Stair tool from the Object Type rollout; the Name
and Color, Parameters, Carriage, Railings, and Stringers rollouts will be displayed.
 
Next, press and hold the left mouse button on the left side of the viewport, drag the cursor to the right
side to specify the length of the stairs, and then release the left mouse button. Now, move the cursor
up to define the width of the stairs and the distance between the two stairways. Click on the screen to
set the width. Next, move the cursor up or down to specify the rise of the stairs. Click on the screen;
the U-type stairs will be created in all viewports. Different U-type stairs are shown in Figures 4-59,
4-60, and 4-61.



Figure 4-59 The U-type stairs

Figure 4-60 The U-type closed stairs

Figure 4-61 The U-type box stairs
 

 
TUTORIALS
Tutorial 1
In this tutorial, you will create a nature scene, as shown in Figure 4-62, using the AEC extended
objects and standard primitives. (Expected time: 30 min)

Figure 4-62 The nature scene
 

The following steps are required to complete this tutorial:
 
a. Create the project folder.
b. Create floor.
c. Create railings.
d. Create trees.
e. Create gate.
f. Save and render the scene.
 
Creating the Project Folder



Create a new project folder with the name c04_tut1 at \Documents\3dsmax2015 and then save the
scene with the name c04tut1, as discussed in Tutorial 1 of Chapter 2.
 
Creating Floor
In this section, you will create a floor using the Plane tool.
 
1. Activate the Top viewport. Choose Create > Geometry in the Command Panel; the Standard

Primitives option is displayed in the drop-down list. Choose the Plane tool from the Object Type
rollout.

 
2. In the Keyboard Entry rollout, set the parameters as follows:
 
Length: 1485.0 Width: 1605.15
 
3. Choose the Create button from the Keyboard Entry rollout; a plane is displayed in viewports.

Now, choose the Zoom Extents All tool to display the entire plane in the viewports.
 
4. In the Name and Color rollout, enter floor; the plane is named as floor.
 
5. Use the color swatch in the Name and Color rollout to modify the color of floor to green.
 
6. Activate the Perspective viewport and set the view using the Zoom and Orbit tools, as shown in

Figure 4-63.

Figure 4-63 The floor geometry after using the Zoom and Orbit tools
 

Creating Railings
In this section, you will create railings around floor using the Railing tool.
 
1. Choose Create > Geometry in the Command Panel; a drop-down list is displayed below the

Geometry button. Select the AEC Extended option from the drop-down list and then choose the
Railing tool from the Object Type rollout.

 
2. Activate the Top viewport. Next, move the cursor to the upper left corner of floor, press and hold



the left mouse button, and drag the cursor to the upper right corner of floor to specify the length of
the railing. Release the left mouse button to set the length, and then move the cursor up to specify
the height of the railing. Click on the viewport; a railing is created.

 
3. In the Name and Color rollout, enter railing01 and press ENTER.
 
4. Use the color swatch to modify the color of railing01 and enter the values as follows:
 
Red: 177 Green: 88 Blue: 26
 
5. Make sure railing01 is still selected. Choose the Modify tab in the Command Panel; the Railing,

Posts, and Fencing rollouts are displayed.
 
6. In the Railing rollout, set the parameters as follows:
 
Length: 1400.0
Top Rail area
Profile: Round Depth: 10.0
Width: 3.0 Height: 100.0
 
Lower Rail(s) area
Profile: Round Depth: 4.0
Width: 3.0
 
7. Choose the Lower Rail Spacing button in the Lower Rail(s) area; the Lower Rail  Spacing

dialog box is displayed. Make sure the Count check box is selected. Next, set the value 3 in the
spinner on the right side of the Count check box and choose the Close button; the railing is
displayed in all viewports, as shown in Figure 4-64.

Figure 4-64 The railing01 displayed in viewports
 
8. In the Posts rollout, set the values as follows:
Profile: Round Depth: 7.0
Width: 5.0 Extension: 2.0



9. Choose the Post Spacing button in the Post rollout; the Post Spacing dialog box is displayed.
Make sure the Count check box is selected. Next, set the value 4 in the spinner on the right side of
the Count check box and choose the Close button.

10. In the Fencing rollout, select (none) from the Type drop-down list.
 

Note
If you want to add fencing to the railing, then select the type of fencing from the Type drop-down
list and set the parameters in the respective area.
 
11. Make sure railing01 is selected in the Top viewport. Now, choose the Select and Move tool

from the Main Toolbar and align the railing manually, as shown in Figure 4-65.
 

Figure 4-65 The railing01 geometry in viewports after aligning it in the Top viewport

 
Next, you need to create one more railing.
 
12. Activate the Top viewport and choose the Railing tool. Create one more railing at the right angle

of railing01 using the same method as discussed for creating railing01, refer to Figure 4-72.
 

Note
When you create another railing, all dimensions of railing01, except the length and height, will be
taken automatically.
 
13. In the Name and Color rollout, enter railing02.
 
14. Assign the same color to railing02 as was assigned to railing01.
 
15. Make sure railing02 is selected. Next, choose the Modify tab in the Command Panel; the

Railing, Post, and Fencing rollouts are displayed.
16. In the Railing rollout, set the parameters as follows:
 
Length: 600.0



Top Rail area
Height: 100.0
 
17. Choose the Select and Move and Select and Rotate tools and align railing02 in the viewports,

as shown in Figure 4-66.

Figure 4-66 The railing02 geometry in viewports after alignment
 
Next, you need to copy railing02.
 
18. Activate the Top viewport. and make sure railing02 is selected. Next, place the cursor over the

vertical axis. Press and hold the SHIFT key and drag railing02 downward until the value in the Y
spinner in the Coordinate display becomes around -601. Release the left mouse button and the
SHIFT key; the Clone Options dialog box is displayed.

 
19. In the Clone Options dialog box, make sure the Copy radio button is selected. Set the value in the

Number of Copies spinner to 1 and enter railing03 in the Name text box. Next, choose the OK
button; railing 03 is created, as shown in Figure 4-67.

Figure 4-67 The railing03 geometry after alignment
20. Activate the Top viewport and select railing03. Choose the Select and Rotate tool, move the

cursor over the Z-axis, and rotate it to -45 degrees in the clockwise direction, as shown in Figure
4-68.

Figure 4-68 The railing03 geometry rotated in the Top viewport



 

Note
While rotating railing03, choose the Angle Snap Toggle tool from the Main Toolbar to measure
the angle of rotation in increments.

 
Now, you need to create the fourth railing.
 
21. Activate the Top viewport and create another railing starting from the endpoint of railing03.
22. In the Name and Color rollout, enter railing04.
 
23. Assign the same color to railing04 as was assigned to railing01.
 
24. Make sure railing04 is selected. Choose the Modify tab in the Command Panel; the Railing,

Post, and Fencing rollouts are displayed.
 
25. In the Railing rollout, set the parameters as follows:
 
Length: 325.0
Top Rail area
Height: 100.0
 
26. Make sure railing04 is aligned in viewports, as shown in Figure 4-69.

Figure 4-69 The railing04 geometry aligned in viewports
 
27. Select railing02, railing03, and railing04 from the Scene Explorer; three railings are selected in the

viewports.
 
28. Make sure the Top viewport is activated and then choose the Mirror tool from the Main Toolbar;



the Mirror: Screen Coordinates dialog box is displayed. In the Mirror Axis area of this dialog
box, make sure the X radio button is selected. In the Offset spinner, set the value -980. In the Clone
Selection area, select the Copy radio button and choose the OK button; the copy of all the railings
created earlier is displayed and they are automatically named as railing005, railing006, and
railing007, refer to Figure 4-70.

 
29. Adjust the view in the Perspective viewport using the tools in the viewport navigation controls,

refer to Figure 4-70.
 

Figure 4-70 The railings geometry displayed in viewports
 

Creating Trees
In this section, you will create the trees using the Foliage tool.
 
1. Choose Create > Geometry in the Command Panel; a drop-down list is displayed below the

Geometry button. Select the AEC Extended option from the drop-down list and then choose the
Foliage tool from the Object Type rollout.

 
2. Activate the Top viewport. In the Favorite Plants rollout, double-click on Generic Palm; the tree

is created and displayed in all viewports.
 

Note
If the Generic Palm tree is not displayed in the palette of the Favorite Plants rollout, then choose
the Plant Library button at the bottom of the rollout; the Configure Palette dialog box is
displayed. Double-click on the Generic Palm tree; the yes option is displayed in the Fav. column,
indicating that the tree will be available in the palette. Next, choose the OK button.
 
3. In the Name and Color rollout, enter tree01; the tree is named as tree01.
 
4. Make sure tree01 is still selected. Choose the Modify tab in the Command Panel; the Parameters

rollout is displayed.
5. In the Parameters rollout, set the following parameters:



 
Height: 300.0
Use the default values for other options.
 
6. In the Top viewport, choose the Select and Move tool and move tree01 toward railing01 in all

viewports, as shown in Figure 4-71.

Figure 4-71 Alignment of tree01 in viewports
 
7. Create multiple copies of tree01 in the Top viewport and align them using the Select and Move

tool, as shown in Figure 4-72.
 
Creating Gate
In this section, you will create a gate using the Pivot and the Cylinder tools.
 
1. Choose Create > Geometry in the Command Panel; a drop-down list is displayed below the

Geometry button. Select the Doors option from the drop-down list and then choose the Pivot tool
from the Object Type rollout.

 
2. Activate the Top viewport and press and hold the left mouse button on the left of the viewport.

Now, drag the cursor to the right of the viewport and release the left mouse button to define the
width. Next, move the cursor up to define the depth of the door and click on the screen to set the
depth. Now, again move the cursor up to define the height of the door. Click on the screen; the pivot
door is created in all viewports.

 
3. In the Name and Color rollout, enter gate.
4. Use the color swatch to modify the color of gate and enter the values as follows:
 
Red: 49 Green: 13 Blue: 6
 



Figure 4-72 Multiple copies of tree01 created and aligned in viewports
 

5. In the Parameters rollout, set the following parameters:
 
Height: 92 Width: 532 Depth: 9.234
Open: 20
 
Also, select the Double Doors and Flip Swing check boxes.
 
6. In the Leaf Parameters rollout, set the following parameters:
 
Thickness: 7.7 Stiles/Top Rail: 6.48 Bottom rail: 13.44
#Panels Horiz.: 6 #Panels Vert.: 4
 
7. In the Panels area, select the Beveled radio button and then set the following parameters:
 
Thickness 1: 0.74 Thickness 2: 1.96 Middle Thick.: 0.991
Width 1: 4.871 Width 2: 1.364
 
8. Align gate using the Select and Move and Select and Rotate tools, as shown in Figure 4-73.
Make sure that there is equal space at both sides of gate to place the rods to be created later.

Figure 4-73 The gate geometry aligned in viewports
 

9. In the Parameters rollout, set 0 in the Open spinner to close gate.



 
Next, you will create rods at both sides of gate.
 
10. Activate the Top viewport. Make sure the Geometry button is chosen in the Command panel. Next,

select Standard Primitives from the drop-down list located below it. Now, choose the Cylinder tool from
the Object Type rollout.

 
11. In the Keyboard Entry rollout, set the parameters as follows:
 
Radius: 2.4 Height: 94
 
Choose the Create button; a cylinder is created.
 
12. In the Name and Color rollout, enter rod1. Also, assign black color to it.
 
13. Align rod1 in the viewports, as shown in Figure 4-74.

 
14. Create a copy of rod1 as done earlier and align it, as shown in Figure 4-75.

 
Next, you will create handles for gate.
 

Figure 4-74 The rod1 geometry aligned in viewports
 



Figure 4-75 The rod2 geometry aligned in viewports
 

15. Activate the Top viewport. Choose Create > Geometry in the Command Panel. Make sure that
the Standard Primitives option is selected in the drop-down list and then choose the Cylinder tool
from the Object Type rollout.

16. In the Keyboard Entry rollout, set the parameters as follows:
 
Radius: 1.5 Height: 35
 
Choose the Create button; a cylinder is created.
 
17. In the Name and Color rollout, enter handle1 and press ENTER. Also, assign black color to it.
 
18. Make sure handle1 is selected. In the Parameters rollout, set 15 in the Height Segments spinner.
 
Next, you will apply Bend modifier to handle1.
 
19. Make sure handle1 is selected and then choose Modifiers > Parametric Deformers > Bend from

the menu bar; the Bend modifier is displayed in the modifier stack. Also, the Parameters rollout is
displayed in the Modify tab.

 
20. In the Parameters rollout of the Bend modifier, set the values as follows:
Bend Area
Angle: 180 Direction: 270
 
Bend Axis area
Make sure the Z radio button is selected.
 
21. Activate the Perspective viewport. Next, align handle1 using the Select and Place tool, as shown in

Figure 4-76.

Figure 4-76 The handle1 geometry aligned
 

22. Activate the Front viewport and create a copy of handle1 and align it, as shown in Figure 4-77.



Figure 4-77 The copy of handle1 aligned
 

Saving and Rendering the Scene
In this section, you will save the scene and then render it. You can also view the final rendered image
of this scene by downloading the c04_3dsmax_2015_rndr.zip file from www.cadcim.com. The path of
the file is as follows: Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max
2015: A Comprehensive Guide
 
1. Change the background color of the scene to light blue, as discussed in Tutorial 1 of Chapter 2,

using the following parameters:
 
Red: 145 Green: 241 Blue: 244
 
2. Choose Save from the Application menu.
 
3. Activate the Perspective viewport. Next, choose the Render Production tool from the Main

Toolbar; the Rendered Frame window is displayed. This window shows the final output of the
scene, refer to Figure 4-78.

 

Figure 4-78 The final output at rendering
 

 
Tutorial 2
In this tutorial, you will create a scene shown in Figure 4-79 using the AEC extended objects and the
standard primitives. (Expected time: 30 min)

 



Figure 4-79 The room model
 

The following steps are required to complete this tutorial:
 
a. Create the project folder.
b. Create the floor.
c. Create railings.
d. Create the room.
e. Create the window.
f. Create the foot support.
g. Create the door.
h. Create trees.
i. Save and render the scene.
Creating the Project Folder
Create a new project folder with the name c04_tut2 at \Documents\3dsmax2015 and then save the
file with the name c04tut2, as discussed in Tutorial 1 of Chapter 2.
 
Creating the Floor
Start Autodesk 3ds Max and reset it as described earlier; a new screen with default settings is
displayed. Next, you need to use the Plane tool from Standard Primitives to create the floor of the
scene.
 
1. Activate the Top viewport and choose Create > Geometry in the Command Panel; the Standard

Primitives option is displayed in the drop-down list. Choose the Plane tool from the Object Type
rollout.

 
2. In the Keyboard Entry rollout, set the parameters as follows:
 
Length: 1100.0 Width: 1200.0
 
3. Choose the Create button from the Keyboard Entry rollout; a plane is created in all viewports.

Choose the Zoom Extents All tool to display the entire plane in all viewports.
 
4. In the Name and Color rollout, enter floor; the plane is named as floor.
 
5. Modify the color of the floor by using the following values:



 
Red: 61 Green: 135 Blue: 6
6. Activate the Perspective viewport and press the G key to hide grids in it. Also, set the view using

the Zoom and Orbit tools, as shown in Figure 4-80.

Figure 4-80 The floor geometry in the Perspective viewport

 
Creating Railings
In this section, you will create railings around floor using the Railing tool.
 
1. Activate the Top viewport and create a railing starting from the upper left corner of floor to its

upper right corner.
2. In the Name and Color rollout, enter railing01.
 
3. Use the color swatch and change the color of railing01 by entering the values as follows:
Red: 177 Green: 88 Blue: 27
 
4. Make sure railing01 is still selected. Choose the Modify tab in the Command Panel; the Railing,

Post, and Fencing rollouts are displayed.
 
5. In the Railing rollout, set the values as follows:
 
Length: 1200.0
 
Top Rail area
Profile: Round Depth: 15.0
Width: 13.0 Height: 100.0
 
Lower Rail(s) area
Profile: Round Depth: 7.0 Width: 7.0
 
6. Choose the Lower Rail Spacing button in the Lower Rail(s) area; the Lower Rail Spacing dialog

box is displayed. Select the Count check box, if it is not already selected, and set the value 3 in the
spinner on the right side of the Count check box and choose the Close button.

 
7. In the Posts rollout, set the values as follows:
Profile: Round Depth: 10.0
Width: 5.0 Extension: 0.0



8. Choose the Post Spacing button in the Post rollout; the Post Spacing dialog box is displayed.
Select the Count check box, if not already selected, and set 5 in the spinner on the right of the
Count check box. Next, choose the Close button.

 
9. In the Fencing rollout, select (none) from the Type drop-down list.
10. Choose the Select and Move tool and align railing01 in viewports, as shown in Figure 4-81.
11. Create the other railings of the same dimension, except the length, to surround floor. Also, activate

the Perspective viewport and set the view using the Pan, Zoom, and Orbit tools, as shown in
Figure 4-82.

 
 

Figure 4-81 The railing01 geometry in viewports after alignment
 

Figure 4-82 The railings geometry displayed in viewports
 

Creating the Room
In this section, you will create the walls of the room using the Wall tool.
 
1. Activate the Top viewport. Choose Create > Geometry in the Command Panel; a drop-down list

is displayed below the Geometry button. Select the AEC Extended option from the drop-down
list and then choose the Wall tool from the Object Type rollout.

2. In the Parameters rollout of the wall, set the values as follows:
 



Width: 5.0 Height: 230.0
 
3. Click on the upper left side of floor to specify the starting point of the wall. Drag the cursor toward

the right to define the length, and then click on the viewport; a wall segment is created. Next, create
another segment of the wall in continuation at the right angle of the first segment. Repeat the same
procedure to create a wall of rectangular shape, refer to Figure 4-83. Now, click on the starting
point of the first wall segment; the Weld Point? message box is displayed. Choose the Yes button to
weld the end points of the wall. Next, right-click to end the creation of the wall.

 

Note
You can modify the wall using the tools in the Select and Scale flyout in the Main Toolbar.
 
4. In the Name and Color rollout, enter wall and press the ENTER key.
 
5. Use the color swatch and change the color of wall by entering the values as follows:
Red: 248 Green: 231 Blue: 120
6. Choose the Select and Move tool and align wall in viewports, as shown in Figure 4-83.

Figure 4-83 The wall geometry displayed in viewports
 

7. Select Standard Primitives from the drop-down list below the Geometry button. Choose the Box
tool from the Object Type rollout to create the roof of wall.

 
8. Activate the Top viewport and create a box.
 
9. In the Name and Color rollout, enter roof.
 
10. Change the color of roof by entering the values as follows:
 
Red: 143 Green: 225 Blue: 87
 
11. In the Parameters rollout, set the values in the Length and Width spinners to cover the upper

portion of the wall. Set the value 5.0 in the Height spinner.
 



12. Choose the Select and Move tool and align roof at the top of the wall in all viewports, refer to
Figure 4-84.

Figure 4-84 The roof geometry in viewports after alignment
 

13. Create a copy of roof as discussed earlier. Next, rename it as room floor and align it on floor.
 

Note
You may need to change the length and width of room floor to align it on floor.
 
14. Change the color of room floor to dark brown.
 
15. Activate the Front viewport and select roof.
16. Choose the Mirror tool from the Main Toolbar; the Mirror: Screen Coordinates dialog box is

displayed. In the Mirror Axis area of this dialog box, select the Y radio button. Next, set the value
in the Offset spinner to 10. In the Clone Selection area, select the Copy radio button and choose
the OK button; roof001 is displayed at the top of roof.

 
17. In the Name and Color rollout, modify the name as roof fencing.
 
18. Use the color swatch to change the color of roof fencing by entering the values as follows:
 
Red: 243 Green: 93 Blue: 47
 
Make sure roof fencing is still selected.
 
19. Right-click on the Select and Uniform Scale tool; the Scale Transform Type-In dialog box is

displayed. Now, in the Offset: Screen area, set the value 105 and press ENTER; roof fencing is
scaled, as shown in Figure 4-85. Close the dialog box.



Figure 4-85 The roof fencing geometry after scaling in the Front viewport
 

Next, you need to create fencing for the corners of wall.
 
20. Activate the Top viewport and choose the Box tool. In the Keyboard Entry rollout, set the values

as follows:
 
Length: 6.0 Width: 1.0 Height: 230.0

 
21. Choose the Create button; a box is displayed in viewports.
 

Note
You may need to adjust the height of the box created, if you have modified the size of the wall
earlier.
 
22. In the Name and Color rollout, enter fc01; the box is named as fc01.

 
23. Assign the same color to fc01 that was assigned to roof fencing.
 
24. Choose the Select and Move tool and align fc01 with wall, as shown in Figure 4-86.

Figure 4-86 The fc01 geometry in the Top viewport after alignment
 

25. Make sure fc01 is selected in the Top viewport and choose the Select and Rotate tool. Now,
press and hold the SHIFT key, move the cursor over the Z-axis, and rotate it until the value in the Z



spinner in the coordinate display becomes 90; the copy of fc01 is created and gets rotated. It is
automatically named as fc002.

 
26. Choose the Select and Move tool and align fc002 with wall, as shown in Figure 4-87.
 
27. Select both fc01 and fc002 by pressing and holding the CTRL key and group them as fencing01.

 
28. Select fencing01 and create its three copies. The copies are automatically named as fencing002,

fencing003, and fencing004. Now, align them at the corners of wall using the Select and Rotate
and Select and Move tools, refer to Figure 4-88. Also, you can use the Zoom tool to view the
corners of wall.

 

Figure 4-87 The fc002 geometry in the Top viewport after alignment
 

29. Choose the Maximize Viewport Toggle tool to view the four viewports, as shown in Figure 4-
94.

 

Note
You can also use the Mirror tool to create copies of fencing01.
 

Figure 4-88 The fencing geometry at the four corners of wall in viewports

 
Creating the Window
In this section, you will create a window by using the Awning tool.
 
1. Activate the Top viewport and select wall from the Scene Explorer. Next, choose Create >

Geometry in the Command Panel; a drop-down list is displayed. Select the Windows option from



the drop-down list and then choose the Awning tool from the Object Type rollout.
 
2. Press and hold the left mouse button and click on the left side of wall. Drag the cursor downward

to specify the width of the window and then release the left mouse button. Next, move the cursor to
the left to define the depth of the window, and then click on the viewport. Now, move the cursor to
the left to specify the height of the window and then click on the viewport; an awning window is
created in viewports.

 
3. In the Name and Color rollout, enter window; the window is named as window.
 
4. Use the color swatch to change the color of window by entering the following values:
 
Red: 135 Green: 59 Blue: 8
 
5. Make sure window is selected. Choose the Modify tab in the Command Panel; the Parameters

rollout is displayed.
 
6. In the Parameters rollout, set the values as follows:
 
Height: 148.826 Width: 106.116 Depth: 10.0
Frame area
Horiz. Width: 8.94 Vert. Width: 8.94 Thickness: 0.5
Glazing area
Thickness: 0.25
 
Rails and Panels area
Width: 14.554 Panel Count: 3
Open Window area
Open: 25
 
You may need to adjust the height, length, and width of window according to wall size in your scene.
7. Use the Select and Move tool to align window on wall in viewports, as shown in Figure 4-89.

 
Creating the Foot Support
In this section, you will create a box primitive to create the foot support.
 
1. Activate the Top viewport and create a box. Next, choose the Modify tab.
 
2. In the Parameters rollout, set the values as follows:
 
Length: 157.098 Width: 135.743 Height: 10.0
3. In the Name and Color rollout, enter foot support and press ENTER.
 



Figure 4-89 The window geometry in viewports after alignment
 

4. Use the color swatch to change the color of the foot support by entering the values as follows:
 
Red: 241 Green: 249 Blue: 200
5. Align foot support with the front side of wall in viewports, as shown in Figure 4-90.

 
Creating the Door
In this section, you will create a door by using the Pivot tool.
 
1. Activate the Top viewport and select wall from the Scene Explorer. Next, choose Create >

Geometry in the Command Panel; a drop-down list is displayed below the Geometry button.
Select the Doors option from the list and choose the Pivot tool from the Object Type rollout.

 
2. Press and hold the left mouse button and click on the front side of wall and then drag the cursor to

the right to specify the width of the door, and then release the left mouse button. Next, move the
cursor upward to define the depth of the door, and then click on the viewport. Now, move the
cursor upward again to specify the height of the door and then click on the viewport; the pivot door
is created in viewports.

 
3. In the Name and Color rollout, enter door as the name of the pivot door and assign it the same

color that was assigned to window.

Figure 4-90 The foot support geometry in viewports after the alignment
 



4. Make sure door is still selected. Choose the Modify tab in the Command Panel; the Parameters
and Leaf Parameters rollouts are displayed.

 
5. In the Parameters rollout, select the Flip Swing check box and set the values as follows:
 
Height: 200.0 Width: 120.341 Depth: 12.0
Open: 30
 
6. In the Frame area of the Parameters rollout, make sure the Create Frame check box is selected and

the values 2.0, 1.0, and 0.0 are specified for the Width, Depth, and Door Offset spinners, respectively.
You may need to set the height and width of the door according to the size of the wall in your scene.
 
7. In the Leaf Parameters rollout, make sure the value 2.0 is specified in the Thickness spinner and

then set the remaining values in the rollout as follows:
 
Bottom Rail: 20.0 # Panels Horiz: 3 # Panels Vert: 4 Muntin: 3.265 Stiles/Top Rail: 10
 
8. In the Panels area of the Leaf Parameters rollout, select the Beveled radio button and make sure the value

45 is specified in the Bevel Angle spinner.
 
Thickness 1: 9.46 Thickness 2: 10.0 Middle Thick: 3.0 Width 1: 3.0 Width 2: 3.0
 
9. Align door in all viewports, as shown in Figure 4-91.

Figure 4-91 The door geometry in viewports after alignment
 

Creating the Trees
In this section, you will create trees by using the Foliage tool from AEC Extended.
 
1. Choose Create > Geometry in the Command Panel; a drop-down list is displayed. Select the

AEC Extended option and choose the Foliage tool from the Object Type rollout.
 
2. Activate the Top viewport. Double-click on the Banyan tree in the Favorite Plants rollout; a tree

is displayed in all viewports.



 
3. In the Name and Color rollout, enter tree01 as the name of the tree.
 
4. Make sure tree01 is still selected. Choose the Modify tab in the Command Panel; the Parameters

rollout is displayed.
 
5. In the Parameters rollout, set the values as follows:
 
Height: 120.0
 
Level-of-Detail area
Select the Medium radio button.
 
Use the default values for other options.
 
6. Choose the Select and Move tool and align tree01 in the Top viewport, as shown in Figure 4-92.

Figure 4-92 The tree01 geometry displayed in viewports after alignment
 

Now, you need to create another tree.
 
7. Activate the Top viewport. Choose the Create tab in the Command Panel and make sure the

Foliage tool is chosen. Now, double-click on the American Elm tree from the Favorite Plants
rollout; the tree is displayed in all viewports.

 
8. In the Name and Color rollout, enter tree02 as the name of the new tree.
9. Choose the Modify tab in the Command Panel; the Parameters rollout is displayed.
 
10. In the Parameters rollout, set the values as follows:
 
Height: 300.0
Use the default values for other options.
 
11. Choose the Select and Move tool and align tree02 in viewports, as shown in Figure 4-93.
 



Figure 4-93 The tree02 geometry in viewports after the alignment
 

Saving and Rendering the Scene
In this section, you will save the scene and then render it. You can also view the final rendered image
of this scene by downloading the c04_3dsmax_2015_rndr.zip file from www.cadcim.com. The path of
the file is as follows: Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max
2015: A Comprehensive Guide

 
1. Change the background color of the scene to light blue, as discussed in Tutorial 1 of Chapter 2,

using the following parameters:
 
Red: 145 Green: 241 Blue: 244
 
2. Choose Save from the Application menu.
 
3. Activate the Perspective viewport. Next, choose the Render Production tool from the Main

Toolbar; the Rendered Frame window is displayed. This window shows the final output of the
scene, refer to Figure 4-94.

 
 

Figure 4-94 The final output of the scene at rendering
 

 
Self-Evaluation Test


